Desert Winds Wireless - West Basin City Outage – Incident details
Report an issue
Get updates
Email
SMS
Microsoft Teams
Webhook
Report an issue
Get updates
Dark mode
All systems operational
West Basin City Outage
Resolved
Major outage
Started 26 days ago
Lasted 3 days
Affected
Tri-Cities (includes Othello/Connell/Basin City...etc)
Major outage from 5:55 PM to 10:26 AM
ENGL
Major outage from 5:55 PM to 10:26 AM
Updates
Resolved
March 12, 2026 at 10:26 AM
Resolved
March 12, 2026 at 10:26 AM
This incident has been resolved.
Investigating
March 09, 2026 at 5:55 PM
Investigating
March 09, 2026 at 5:55 PM
We are currently investigating this incident.