Desert Winds Wireless - BADG Emergency Maintenance – Incident details

All systems operational

BADG Emergency Maintenance

Resolved
Under maintenance
Started 7 months agoLasted about 13 hours

Affected

Tri-Cities (includes Othello/Connell/Basin City...etc)

Under maintenance from 5:23 PM to 6:01 AM

BADG

Under maintenance from 5:23 PM to 6:01 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Identified
    UTC
    Identified

    We ran into technical difficulties and this is taking longer than anticipated. We thank you for your patience as we work to restore services as soon as possible.

  • Investigating
    UTC
    Investigating

    Equipment on Badger tower has been experiencing many issues as of late. Tech are on site working to rectify these issues. Service may experience brief outages.