Desert Winds Wireless - Outage: Chewlah & Colville surrounding areas – Incident details

CHEW experiencing major outage

Outage: Chewlah & Colville surrounding areas

Resolved
Major outage
Started 1 day agoLasted about 18 hours

Affected

Colville

Major outage from 2:51 AM to 8:59 PM

EAGLE

Major outage from 2:51 AM to 8:59 PM

BACON

Major outage from 2:51 AM to 8:59 PM

ZIMM

Major outage from 2:51 AM to 8:59 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Power is out and Avista says the power pole is privately owned and will not be replaced by them. We are acquiring a generator and continuing to work on a fix for this incident.

  • Identified
    Identified

    One of the power poles has broken & fallen over. We believe Avista is currently repairing this pole.

  • Investigating
    Investigating
    We are currently investigating this incident.