Desert Winds Wireless - DART outage – Incident details
Report an issue
Get updates
Email
SMS
Microsoft Teams
Webhook
Report an issue
Get updates
Dark mode
CHEW experiencing major outage
DART outage
Resolved
Major outage
Started 14 days ago
Lasted about 1 hour
Affected
Tri-Cities (includes Othello/Connell/Basin City...etc)
Major outage from 8:24 PM to 9:19 PM
DART
Major outage from 8:24 PM to 9:19 PM
Updates
Resolved
July 30, 2025 at 9:19 PM
Resolved
July 30, 2025 at 9:19 PM
This incident has been resolved.
Investigating
July 30, 2025 at 8:24 PM
Investigating
July 30, 2025 at 8:24 PM
We are currently investigating this incident.