Desert Winds Wireless - English Hay Outage – Incident details
Report an issue
Get updates
Email
SMS
Microsoft Teams
Webhook
Report an issue
Get updates
Dark mode
All systems operational
English Hay Outage
Resolved
Major outage
Started 2 months ago
Lasted about 1 hour
Affected
Tri-Cities (includes Othello/Connell/Basin City...etc)
Major outage from 10:35 PM to 12:01 AM
ENGL
Major outage from 10:35 PM to 12:01 AM
Updates
Resolved
February 27, 2025 at 12:01 AM
Resolved
February 27, 2025 at 12:01 AM
This incident has been resolved.
Investigating
February 26, 2025 at 10:35 PM
Investigating
February 26, 2025 at 10:35 PM
We are currently investigating this incident.