Desert Winds Wireless - Basin City Outage – Incident details

All systems operational

Basin City Outage

Resolved
Operational
Started 4 months agoLasted 21 minutes

Affected

Tri-Cities (includes Othello/Connell/Basin City...etc)

Major outage from 9:58 PM to 10:19 PM

ENGL

Major outage from 9:58 PM to 10:19 PM

CSPR

Major outage from 9:58 PM to 10:19 PM

WHIT

Major outage from 9:58 PM to 10:19 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Power has been restored for now. We've been lied to before.

  • Investigating
    Investigating

    We are currently investigating this incident as a power outage issue.