Desert Winds Wireless - Ruby Surrounding Area Outage – Incident details
Report an issue
Get updates
Email
SMS
Microsoft Teams
Webhook
Report an issue
Get updates
Dark mode
All systems operational
Ruby Surrounding Area Outage
Resolved
Major outage
Started about 2 months ago
Lasted about 4 hours
Affected
Tri-Cities (includes Othello/Connell/Basin City...etc)
Major outage from 1:40 PM to 5:34 PM
DBBL
Major outage from 1:40 PM to 5:34 PM
Updates
Resolved
January 04, 2026 at 5:34 PM
Resolved
January 04, 2026 at 5:34 PM
This incident has been resolved.
Investigating
January 04, 2026 at 1:40 PM
Investigating
January 04, 2026 at 1:40 PM
We are currently investigating this incident.