Desert Winds Wireless - Power outage in Chaffee and Benton City Surrouding Area – Incident details

ARDN experiencing major outage

Power outage in Chaffee and Benton City Surrouding Area

Resolved
Major outage
Started 3 months agoLasted 1 day

Affected

Tri-Cities (includes Othello/Connell/Basin City...etc)

Major outage from 12:51 AM to 1:27 AM, Operational from 5:00 AM to 11:53 PM, Major outage from 11:53 PM to 3:10 AM

YKTT

Major outage from 12:51 AM to 1:27 AM, Operational from 5:00 AM to 11:53 PM, Major outage from 11:53 PM to 3:10 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    There is another outage posted by BentonPUD for this area. This has unfortunately affected our services in the vicinity as well.

  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have recently learned that Franklin PUD is reporting a power outage in the area. However, they have not provided an ETR at this time. We'll continue to monitor this and provide updates once available.

  • Investigating
    Investigating
    We are currently investigating this incident.