Desert Winds Wireless - Weather affecting English Hay – Incident details
Report an issue
Get updates
Email
SMS
Microsoft Teams
Webhook
Report an issue
Get updates
Dark mode
All systems operational
Weather affecting English Hay
Resolved
Major outage
Started about 1 month ago
Lasted about 1 hour
Affected
Tri-Cities (includes Othello/Connell/Basin City...etc)
Major outage from 1:28 AM to 2:48 AM
ENGL
Major outage from 1:28 AM to 2:48 AM
Updates
Resolved
March 28, 2025 at 2:48 AM
Resolved
March 28, 2025 at 2:48 AM
This incident has been resolved.
Identified
March 28, 2025 at 1:28 AM
Identified
March 28, 2025 at 1:28 AM
We are continuing to work on a fix for this incident.