Desert Winds Wireless - Outage effecting North Ritzville, Marcellus, Keystone – Incident details

All systems operational

Outage effecting North Ritzville, Marcellus, Keystone

Resolved
Major outage
Started 3 months agoLasted 23 minutes

Affected

Ritzville

Major outage from 9:45 PM to 10:08 PM

TOKI

Major outage from 9:45 PM to 10:08 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.