Desert Winds Wireless - South eastern Colville outage – Incident details

All systems operational

South eastern Colville outage

Resolved
Operational
Started 4 months agoLasted about 2 hours

Affected

Colville

Major outage from 1:23 AM to 2:58 AM

BACON

Major outage from 1:23 AM to 2:58 AM

Updates
  • Resolved
    Resolved

    Power has been restored to the site.

  • Identified
    Identified

    This looks to be a Power outage in the area.

  • Investigating
    Investigating
    We are currently investigating this incident.