Desert Winds Wireless - Basin City Outage – Incident details

All systems operational

Basin City Outage

Resolved
Operational
Started 5 months agoLasted less than a minute

Affected

Tri-Cities (includes Othello/Connell/Basin City...etc)

Operational from 5:40 PM to 5:40 PM

ENGL

Operational from 5:40 PM to 5:40 PM

CSPR

Operational from 5:40 PM to 5:40 PM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    The tower briefly lost power. This has been resolved and service has been restored.